Skip to content
LogoCafu Engine documentation
Project Home Forum Documentation Issue Tracker
⌘ K
LogoCafu Engine documentation
Project Home Forum Documentation Issue Tracker

User Documentation

  • Quick Start
  • Installation
  • Running Cafu

General

  • User FAQ
  • Developer FAQ

The Map Editor

  • Installation, Initial Configuration and De-Installation
  • Getting Started
    • Introduction to Editing
    • The Main Window User Interface
    • 2D and 3D Views
    • The Material Browser
    • Your First Map
  • Map Editing Tools
    • The Selection Tool
    • The Camera Tool
    • The New Brush Tool
    • The New Entity Tool
    • The New Bezier Patch Tool
    • The New Terrain Tool
    • The New Light Tool
    • The New Decal Tool
    • The Edit Surface Properties Tool
    • The Edit Terrain Tool
    • The Clipping Tool
    • The Edit Vertices (Morph) Tool
  • Selected Topics
    • Groups
    • Dealing with Leaks
    • Creating Teleporter Stations
    • About Lights and Shadows
    • Importing Maps from other Games/Editors
    • Method One: Creating a skybox
    • Placing Water
  • Menu Reference
    • The File Menu
    • The Edit Menu
    • The Map Menu
    • The View Menu
    • The Tools Menu
    • The Compile Menu
    • The Window Menu
    • The Help Menu
  • Dialog Reference
    • The Configure CaWE Options Dialog
    • The Replace Materials Dialog
    • The Paste Special Dialog
    • The Find Entities Dialog
    • The Object Properties Dialog
    • The Goto Brush/Entity Dialog
    • The Entity Report Dialog
    • The Map Error Report Dialog
    • The Transform Type-In Dialog
    • The Surface Properties Dialog
    • The Entity Inspector Dialog
  • Entity Guide
  • Compiling Maps for Cafu
  • Compiling Maps at the Command-Line
  • Creating Height-Maps for your Terrains

The GUI Editor

  • The Font Wizard: Creating new fonts
  • GUI Files Explained

The Model Editor

  • The Model Editor: Introduction
  • The Main Window
  • How-Tos
  • Model Elements
    • Skeleton
    • Meshes
    • Skins
    • GUI Fixtures
    • Animations
    • Channels
  • Program Dialogs
    • Scene Setup
    • Submodels
    • Level-of-Detail Models
    • Transforms: translate, rotate and scale
  • Menu and Toolbar Reference
  • Model Files Explained
  • Dependencies among Models

Textures

  • Supported file formats
  • Texture types
  • Skybox creation (Environmental Map, Cubemap)
  • Using own textures
  • Making “perfect” Detail-Maps

The Material System

  • What is it? An Introduction
  • The Materialviewer
  • The Materials (cmat files) Manual
    • Overview
    • Texture Map Specifications
    • Shader Specifications
    • Expressions and Tables
    • Keyword Reference

The Cafu Source Code

  • Getting Started with the Cafu Source Code
  • How to Submit Patches
  • Coding Conventions
  • Selected Topics
    • Game Development Overview
    • Starting your own Game
    • Loading game worlds
    • Using the Autodesk FBX SDK
Cafu Engine documentation
/
Menu Reference

Menu Reference

Contents:

  • The File Menu
    • New
    • Open…
    • Close
    • Save
    • Save as…
    • Configure CaWE…
    • Exit
    • Most recently used maps
  • The Edit Menu
    • Undo
    • Redo
    • Cut
    • Copy
    • Paste
    • Paste Special…
    • Delete
    • Select None
    • Select All
    • Find Entities…
    • Object Properties
  • The Map Menu
    • Snap to grid
    • Show grid
    • Grid settings
    • Units
    • Go to Brush Number…
    • Show Information
    • Entity Report
    • Check for Problems…
    • Map Properties
    • Load Pointfile
    • Unload Pointfile
  • The View Menu
    • Screen Elements
    • 2D X/Y
    • 2D Y/Z
    • 2D X/Z
    • 3D Wireframe
    • 3D Filled Polygons
    • 3D Textured Polygons
    • Center Splitters (2x2 Views)
    • Center 2D Views on Selection
    • Center 3D Views on Selection
    • Show Connections
    • Show Helpers
    • Hide Items
    • Hide Paths
    • Hide Entity Names
    • Hide Selected Objects
    • Show Hidden Objects
  • The Tools Menu
    • CaWE Tools
    • Carve
    • Make Hollow
    • Group
    • Ungroup
    • Tie to Entity
    • Move to World
    • Replace Materials
    • Material Lock
    • Snap Selection to Grid
    • Transform
    • Align Objects
    • Flip Objects
  • The Compile Menu
    • Compile Options
    • Quick
    • Normal
    • High Quality
    • Abort
  • The Window Menu
    • Cascade
    • Tile Horizontally
    • Tile Vertically
    • Arrange Icons
    • Next
    • Previous
    • Currently opened maps
  • The Help Menu
    • CaWE Help
    • CaWE Website
    • CaWE Forum
    • About…

© Carsten Fuchs Built with Sphinx 8.2.3