Skip to content
LogoCafu Engine documentation
Project Home Forum Documentation Issue Tracker
⌘ K
LogoCafu Engine documentation
Project Home Forum Documentation Issue Tracker

User Documentation

  • Quick Start
  • Installation
  • Running Cafu

General

  • User FAQ
  • Developer FAQ

The Map Editor

  • Installation, Initial Configuration and De-Installation
  • Getting Started
    • Introduction to Editing
    • The Main Window User Interface
    • 2D and 3D Views
    • The Material Browser
    • Your First Map
  • Map Editing Tools
    • The Selection Tool
    • The Camera Tool
    • The New Brush Tool
    • The New Entity Tool
    • The New Bezier Patch Tool
    • The New Terrain Tool
    • The New Light Tool
    • The New Decal Tool
    • The Edit Surface Properties Tool
    • The Edit Terrain Tool
    • The Clipping Tool
    • The Edit Vertices (Morph) Tool
  • Selected Topics
    • Groups
    • Dealing with Leaks
    • Creating Teleporter Stations
    • About Lights and Shadows
    • Importing Maps from other Games/Editors
    • Method One: Creating a skybox
    • Placing Water
  • Menu Reference
    • The File Menu
    • The Edit Menu
    • The Map Menu
    • The View Menu
    • The Tools Menu
    • The Compile Menu
    • The Window Menu
    • The Help Menu
  • Dialog Reference
    • The Configure CaWE Options Dialog
    • The Replace Materials Dialog
    • The Paste Special Dialog
    • The Find Entities Dialog
    • The Object Properties Dialog
    • The Goto Brush/Entity Dialog
    • The Entity Report Dialog
    • The Map Error Report Dialog
    • The Transform Type-In Dialog
    • The Surface Properties Dialog
    • The Entity Inspector Dialog
  • Entity Guide
  • Compiling Maps for Cafu
  • Compiling Maps at the Command-Line
  • Creating Height-Maps for your Terrains

The GUI Editor

  • The Font Wizard: Creating new fonts
  • GUI Files Explained

The Model Editor

  • The Model Editor: Introduction
  • The Main Window
  • How-Tos
  • Model Elements
    • Skeleton
    • Meshes
    • Skins
    • GUI Fixtures
    • Animations
    • Channels
  • Program Dialogs
    • Scene Setup
    • Submodels
    • Level-of-Detail Models
    • Transforms: translate, rotate and scale
  • Menu and Toolbar Reference
  • Model Files Explained
  • Dependencies among Models

Textures

  • Supported file formats
  • Texture types
  • Skybox creation (Environmental Map, Cubemap)
  • Using own textures
  • Making “perfect” Detail-Maps

The Material System

  • What is it? An Introduction
  • The Materialviewer
  • The Materials (cmat files) Manual
    • Overview
    • Texture Map Specifications
    • Shader Specifications
    • Expressions and Tables
    • Keyword Reference

The Cafu Source Code

  • Getting Started with the Cafu Source Code
  • How to Submit Patches
  • Coding Conventions
  • Selected Topics
    • Game Development Overview
    • Starting your own Game
    • Loading game worlds
    • Using the Autodesk FBX SDK
Cafu Engine documentation
/
Model Elements

Model Elements

Contents:

  • Skeleton
    • The joints hierarchy
    • The joint inspector
  • Meshes
    • The meshes list
    • The mesh inspector
  • Skins
    • The skins list
    • The skin inspector
  • GUI Fixtures
    • The GUI fixtures list
    • The GUI fixture inspector
    • Example video
  • Animations
    • The animations list
    • The animation inspector
  • Channels
    • The channels list
    • The channel inspector

© Carsten Fuchs Built with Sphinx 8.2.3