Skip to content
LogoCafu Engine documentation
Project Home Forum Documentation Issue Tracker
⌘ K
LogoCafu Engine documentation
Project Home Forum Documentation Issue Tracker

User Documentation

  • Quick Start
  • Installation
  • Running Cafu

General

  • User FAQ
  • Developer FAQ

The Map Editor

  • Installation, Initial Configuration and De-Installation
  • Getting Started
    • Introduction to Editing
    • The Main Window User Interface
    • 2D and 3D Views
    • The Material Browser
    • Your First Map
  • Map Editing Tools
    • The Selection Tool
    • The Camera Tool
    • The New Brush Tool
    • The New Entity Tool
    • The New Bezier Patch Tool
    • The New Terrain Tool
    • The New Light Tool
    • The New Decal Tool
    • The Edit Surface Properties Tool
    • The Edit Terrain Tool
    • The Clipping Tool
    • The Edit Vertices (Morph) Tool
  • Selected Topics
    • Groups
    • Dealing with Leaks
    • Creating Teleporter Stations
    • About Lights and Shadows
    • Importing Maps from other Games/Editors
    • Method One: Creating a skybox
    • Placing Water
  • Menu Reference
    • The File Menu
    • The Edit Menu
    • The Map Menu
    • The View Menu
    • The Tools Menu
    • The Compile Menu
    • The Window Menu
    • The Help Menu
  • Dialog Reference
    • The Configure CaWE Options Dialog
    • The Replace Materials Dialog
    • The Paste Special Dialog
    • The Find Entities Dialog
    • The Object Properties Dialog
    • The Goto Brush/Entity Dialog
    • The Entity Report Dialog
    • The Map Error Report Dialog
    • The Transform Type-In Dialog
    • The Surface Properties Dialog
    • The Entity Inspector Dialog
  • Entity Guide
  • Compiling Maps for Cafu
  • Compiling Maps at the Command-Line
  • Creating Height-Maps for your Terrains

The GUI Editor

  • The Font Wizard: Creating new fonts
  • GUI Files Explained

The Model Editor

  • The Model Editor: Introduction
  • The Main Window
  • How-Tos
  • Model Elements
    • Skeleton
    • Meshes
    • Skins
    • GUI Fixtures
    • Animations
    • Channels
  • Program Dialogs
    • Scene Setup
    • Submodels
    • Level-of-Detail Models
    • Transforms: translate, rotate and scale
  • Menu and Toolbar Reference
  • Model Files Explained
  • Dependencies among Models

Textures

  • Supported file formats
  • Texture types
  • Skybox creation (Environmental Map, Cubemap)
  • Using own textures
  • Making “perfect” Detail-Maps

The Material System

  • What is it? An Introduction
  • The Materialviewer
  • The Materials (cmat files) Manual
    • Overview
    • Texture Map Specifications
    • Shader Specifications
    • Expressions and Tables
    • Keyword Reference

The Cafu Source Code

  • Getting Started with the Cafu Source Code
  • How to Submit Patches
  • Coding Conventions
  • Selected Topics
    • Game Development Overview
    • Starting your own Game
    • Loading game worlds
    • Using the Autodesk FBX SDK
Cafu Engine documentation
/
Menu and Toolbar Reference

Menu and Toolbar Reference

This section lists the menu and toolbar items that are available in the Model Editor.

The Toolbar

image0

New

and Open: In the Model Editor, as new models cannot be created from scratch, these two buttons serve the same purpose: They open the dialog for loading or importing model files.

Save

Saves the model under the current name.

Save As…

Saves the model under a new name.

Undo

Un-does the previously made change to the model.

Redo

Re-does a previously undone change.

Cut

, Copy and Paste: These three are not yet implemented in the Model Editor.

Delete

If the currently selected model element can be deleted, this button deletes it.

Animation playback

play or pause the currently selected animation sequence, or switch to the previous or next available sequence in the animations list.

Transform model

Opens the Transform Model dialog.

Add GUI fixture

Adds a new GUI fixture to the model.


The File menu

image1

New

Opens the dialog for creating a new map or new GUI, or for importing a model.

Open…

Opens the dialog for loading or importing a map, a GUI or a model.

Close

Closes the currently active file.

Save

Saves the file under the same name.

Save As…

Saves the file under a new name.

Configure CaWE…

Opens the Configure CaWE dialog.

Exit

Checks if all modified files have been saved and quits the application.

Recently opened files

This part of the menu lists the most recently opened files. Select one to open it.


The Edit menu

image2

Undo

Un-does the previously made change to the model.

Redo

Re-does a previously undone change.

Cut

, Copy and Paste: These three are not yet implemented in the Model Editor.

Delete

If the currently selected model element can be deleted, this button deletes it.


The View menu

image3 The View menu items open and close the dialogs and panes of the Model Editor: Check an item to show the related pane, and un-check the item to hide it again.

This is especially useful if you’ve accidentally closed a pane that you want to bring up again.

The Model menu

image4

Play anim

and Pause anim: Like the related toolbar buttons, play and pause the currently selected animation sequence.

Transform…

Opens the Model Transform dialog.

Add…

or Import…: These items are the menu equivalents to the “+” buttons in the model element lists: The add or import a new model element of the specified type.

Run benchmark

This is not yet implemented.

Load submodel…

and Unload submodel: Loads and unloads submodels, just like the “+” and “-” buttons of the Submodels dialog.


The Window menu

image5 As in all of the Map, GUI and Model Editors, the Window menu can be used to arrange and change to the currently opened windows.

The Help menu

image6 As in all of the Map, GUI and Model Editors, the Help menu opens the web browser with related websites for help and support, and shows the CaWE About dialog.

On this page

  • The Toolbar
  • The File menu
  • The Edit menu
  • The View menu
  • The Model menu
  • The Window menu
  • The Help menu

© Carsten Fuchs Built with Sphinx 8.2.3